Back to overview
Degraded

Service Degradation

Aug 12 at 02:55pm MDT
Affected services
Main Website
Support Desk
Z96 Mix - KCZH

Resolved
Aug 14 at 04:03pm MDT

The issue has been resolved!

Created
Aug 12 at 02:55pm MDT

We're experiencing some intermittent issues with our web provider that our Main, Support, and Z96 Mix are hosted from. This issue may result in temporary denial of service to the sites. Please know that we are aware of the issue and are working to remedy the issue.

NOTE: This issue does NOT affect our streaming services since those servers sit on different infrastructure.